X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   News and Announcements (https://forum.x-cart.com/forumdisplay.php?f=28)
-   -   X-Cart 5.3.1.4 and 5.2.19 Released to Ensure Stable Upgrade to 5.3 for Live Stores (https://forum.x-cart.com/showthread.php?t=74528)

Anna_Shvetsova 10-13-2016 08:50 AM

X-Cart 5.3.1.4 and 5.2.19 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
Hi friends,

Today we've released two new versions, 5.3.1.4 and 5.2.18. Both are mainly devoted to improvements in upgrading process from 5.2 to 5.3.
https://blog.x-cart.com/x-cart-5-3-1-4-and-5-2-18-released.html
Your feedback is much appreciated!

CenturyPerf 10-13-2016 10:48 AM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
Update to 5.3.1.4 hangs when trying to unpack archives. Tried both Firefox and Chrome.

kevinrm 10-14-2016 08:11 PM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
Upgraded from 5.2.17 to 5.2.18, then to 5.3.1.4 - the whole thing went extremely smooth. It appears the dream of smooth XC5 upgrades have finally become a reality.

That said, I'll still run them on the development store first!

Is it my imagination, or does XC 5.3.x run a lot faster than XC 5.2.x?

Triple A Racing 10-14-2016 10:50 PM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
We're a bit more cautious than you @kevinrm despite us having a much simpler store setup :wink:

Our Dev Store 5.2.17 upgrade was was indeed smooth and easy, just like you said. There is a teeny glitch in the verification check though, as prior to submitting the upgrade, we got a caution type notice saying that a file had been 'modified' On close inspection, it's because the upgrade is adding a new file that wasn't there before and actually has no XC5 purpose. The file that XC5.2.17 identifies prior to running the XC5.2.18 upgrade and then adds, is this one:
Code:

/skins/admin/en/modules/CDev/TinyMCE/js/tinymce/plugins/filemanager/js/.DS_Store
It's part of the TinyMCE integration module upgrade. This DS_Store file is just an OSX Desktop Services Store file that has been carried over from somebody's OSX desktop at XC, so it's not a big trauma. It has zero effect on the upgrade, but you do have to go and delete it off your server afterwards. A slight correction before the merchant wave is released would be handy for people. We'll be upgrading our live store to 5.2.18 in the merchant wave. Meanwhile, the 5.2.18 version on our dev store runs with no faults or imperfections which is nice!

We are going to wait for the merchant wave release of 5.3.14 too, as that upgrade (on our 5.2.18 dev store initially) will be a big learning curve. We have all our customisations / alterations contained within /skins/custom_skin and all these must be converted to twig manually... much coffee & patience :D/

One question? Are you not running 5.3.1.4 on PHP7? That should definitely add some processing speed too. Once the merchant wave is released, we can and will run our 5.2.18 live store on PHP 5.6.23 and our 5.3.1.4 dev store on PHP 7.0.8 with the config change made via .htaccess. Maybe you can do the same?

kevinrm 10-14-2016 11:08 PM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
The merchant wave of 5.3.1.4 has already released, I never upgrade unless it's merchant wave.

There was a tinymce module upgrade when I went from 5.2.17 to 5.2.18. That was already taken care of before the jump to 5.3

We are running this on PHP 5.6.22. I had been waiting to upgrade to 5.3 before upgrading to PHP 7. When it comes to this cart, I like to take these things in baby steps, one by one. I will tackle that soon.

By the way, I ran this upgrade from 5.2.18 to 5.3.1.4 in one wave, all modules and core all at the same time and it went completely smooth. I did that based on the behavior of the development store - zero problems.

Triple A Racing 10-14-2016 11:42 PM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
Quote:

Originally Posted by kevinrm
The merchant wave of 5.3.1.4 has already released, I never upgrade unless it's merchant wave

Ahhh we see. Thanks. The 5.2.1.8 is still at developer wave at the time of us writing this reply, so we assumed that 5.3.1.4 would be too
Quote:

Originally Posted by kevinrm
There was a tinymce module upgrade when I went from 5.2.17 to 5.2.18

Yep that's the one we are referring too. Did you get the extra unnecessary file? (check your server...)
Quote:

Originally Posted by kevinrm
We are running this on PHP 5.6.22. I had been waiting to upgrade to 5.3 before upgrading to PHP 7

We ran a trial XC 4.7.6 on PHP 7 with our old archive 4.1.9 still on PHP 4... Despite the obvious XC improvements, PHP 7 ran faultlessly as did 4.7.6 when using it, albeit only as a trial but we think there was more of a risk with the XC 5.3.1.4 upgrade than with using PHP 7 though
Quote:

Originally Posted by kevinrm
By the way, I ran this upgrade from 5.2.18 to 5.3.1.4 in one wave, all modules and core all at the same time and it went completely smooth. I did that based on the behavior of the development store - zero problems

Nice to hear :D/ What about your own customisations / alterations? Where they all within Custom CSS/JS and Webmaster Mode? That should indeed make it smooth and easy unlike skins/custom_skin which must be done manually.

kevinrm 10-15-2016 12:11 AM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
Well, first of all - XC 5.2.18 is also already released as merchant wave. You may want to refresh your cache. When you do that, you will most likely see a tinymce module update as well.

Our custom CSS survived all the upgrades. We had 4 or 5 custom modules made by Qualteam, I paid to have those upgraded to XC 5.3 about a week ago, they were built on a 5.3 development copy we had. When it came to this upgrade, those also smoothly upgraded. I literally had zero issues going from 5.2.17 to 5.3.1.4, your results may vary.

Triple A Racing 10-15-2016 12:48 AM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
Quote:

Originally Posted by kevinrm
XC 5.2.18 is also already released as merchant wave

:wink: No it's not a simple cache issue. Our dev store(s) is set at developer, so the message came and it upgraded easily to 5.2.18 as we said, apart from the tinymce module glitch that we posted about before. Our live store is set at merchant, is currently on 5.2.17 and has no upgrades available at present. Sometimes the merchant waves themselves are released in waves (!) so we're guessing it's just that
Quote:

Originally Posted by kevinrm
Our custom CSS survived all the upgrades

Yeah it should do really as that's the XC plan. Great to read that this bit works properly even though we don't use it. Modules are a different subject as they can be unique to each end-user, so as you posted before "results may vary"

We will run the 5.3.1.4 upgrade on our dev store but it will be early next week before we do.

Triple A Racing 10-15-2016 07:59 PM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
@kevinrm Patience ran out :mrgreen: so FWIW...

The message finally arrived, so we ran the 5.2.18 upgrade on our live store. Another easy, smooth faultless transition (the extra DS-Store file glitch is still there but it's easy to solve) We'll run live like this for a while now.

Being on a roll, we then ran a dev store 5.2.18 > 5.3.1.4 upgrade and again, another easy, smooth faultless transition. Nice! Our 5.2.18 > 5.3.1.4 upgrade will be as close to 'vanilla' as possible we think, thanks to our own choice of how we are applying customisation. So it's only right that it was as smooth as it could be.

Now the hard work of manually converting all our customisations / alterations etc into twig (all of which are contained within /skins/custom_skin) so that this store looks like our 5.2.18 live store :wink: I am just going outside and may be some time...(sic) Captain Oats

You can see in our sig that our 5.3.1.4 dev store is running very well on PHP7 if that's of any help to you.

qualiteam 10-16-2016 05:29 AM

Re: X-Cart 5.3.1.4 and 5.2.18 Released to Ensure Stable Upgrade to 5.3 for Live Stores
 
Quote:

Originally Posted by kevinrm
Is it my imagination, or does XC 5.3.x run a lot faster than XC 5.2.x?


Yes, it should be faster:
https://blog.x-cart.com/5-3-beta.html#performance

And with PHP7 the performance should increase more.

Here is the comparison table made from our testing results (Response Time / 100 new users per minute):
Code:

                                  XC5.2    XC5.3    XC5.3
                                  PHP 5.5  PHP 5.5  PHP 7

Home page:                        1.285    0.610    0.422
Category page:                    1.139    0.606    0.406
Product page:                      1.286    0.587    0.290
Cart page with added product:      1.148    0.587    0.286
Category page with added product:  3.640    0.651    0.434
Home page with added product:      3.217    0.425    0.247
Global average:                    1.232    0.536    0.329



All times are GMT -8. The time now is 12:54 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.