X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   X-Payments issues & questions (https://forum.x-cart.com/forumdisplay.php?f=50)
-   -   Subscription status: Not created (https://forum.x-cart.com/showthread.php?t=76305)

Gunstar1 06-06-2018 12:20 PM

Subscription status: Not created
 
I have seen a few of these now on subscriptions with a successful checkout. There are not many, maybe 10 in the last 200 subscriptions, but still there seems to be some sort of problem.

Below is an x-payment connector error for the same time as the latest "not created".

Code:

[05-Jun-2018 20:55:51] xpay_connector message:
    Process callback data. Transaction id is not found
Request URI: /store/payment/cc_xpc.php
Backtrace:
/public_html/store/modules/XPayments_Connector/xpc_func.php:2278
/public_html/store/modules/XPayments_Connector/xpc_func.php:862
/public_html/store/payment/cc_xpc.php:380


However, I get this error showing up in the logs a number of times (30 in the last 400 orders).

If I were to guess, it is that the when one of the above errors happens and it is for a subscription, that is the cause of the "not created". Though I am not sure.

Any ideas on why this error is happening? Some timeout or something I have set too low on my server? X-payments is hosted, but xcart is on my own server.

random 06-08-2018 11:44 AM

Re: Subscription status: Not created
 
Quote:

Originally Posted by Gunstar1
I have seen a few of these now on subscriptions with a successful checkout. There are not many, maybe 10 in the last 200 subscriptions, but still there seems to be some sort of problem.

Below is an x-payment connector error for the same time as the latest "not created".

Code:

[05-Jun-2018 20:55:51] xpay_connector message:
    Process callback data. Transaction id is not found
Request URI: /store/payment/cc_xpc.php
Backtrace:
/public_html/store/modules/XPayments_Connector/xpc_func.php:2278
/public_html/store/modules/XPayments_Connector/xpc_func.php:862
/public_html/store/payment/cc_xpc.php:380


However, I get this error showing up in the logs a number of times (30 in the last 400 orders).

If I were to guess, it is that the when one of the above errors happens and it is for a subscription, that is the cause of the "not created". Though I am not sure.

Any ideas on why this error is happening? Some timeout or something I have set too low on my server? X-payments is hosted, but xcart is on my own server.


Probably these error log entries were caused by the fact that callback from X-Payments about placed order reached your server earlier than X-Cart actually stored the order in database. That is not an issue generally because order status is updated also when customer payment is completed.

So, deeper investigation of this issues is required. You may contact our technical support team on this matter.


All times are GMT -8. The time now is 08:43 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.