X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   News and Announcements (https://forum.x-cart.com/forumdisplay.php?f=28)
-   -   X-Cart 5.4.0 Public Beta is out (https://forum.x-cart.com/showthread.php?t=76913)

mvs 05-02-2019 11:40 PM

Re: X-Cart 5.4.0 Public Beta is out
 
Quote:

Originally Posted by Triple A Racing
Still..... no news yet from XC about the availability of the revised Public Beta Release of XC5.4.*.* :D/ As well as the questions / answers posted previously in this thread on the initial release, others have posted issues in here: https://forum.x-cart.com/forumdisplay.php?f=59


We will release revised 5.4.0.x Public Beta with PHP 7.3 and MariaDB fixes next week. I’ll post an update here. Thank you for understanding.

mvs 05-10-2019 03:41 AM

Re: X-Cart 5.4.0 Public Beta is out
 
Anyone who have problems with the installation using PHP 7.3 please attach log files from the xcart_folder/var/log directory, it will help us to investigate this issue. Thanks!

cflsystems 05-10-2019 05:02 AM

Re: X-Cart 5.4.0 Public Beta is out
 
Max FYI
It looks like the new XC5 pack is not .tar anymore but .tgz
I can't re-install any package packed from admin. Error message was something like unknown format or similar.

Am I missing something here or is this another bug in the XC 5.4.x beta?

mvs 05-13-2019 01:05 AM

Re: X-Cart 5.4.0 Public Beta is out
 
Quote:

Originally Posted by cflsystems
Max FYI
It looks like the new XC5 pack is not .tar anymore but .tgz
I can't re-install any package packed from admin. Error message was something like unknown format or similar.

Am I missing something here or is this another bug in the XC 5.4.x beta?

The problem is that you cannot upload the module for X-Cart 5.3.6.x on X-Cart 5.4.0.x. And tar/tgz/tar.gz formats are acceptable.

To adapt your module you need to manually unpack the version for 5.3.6.x in root X-Cart 5.4.0.x and make the necessary changes:
- Main.php -> main.yaml (possible to generate via command: php xc5 utils:generateMainYaml XC/Example)
- Change module version to 5.4.0.0
- Rebuild the cache
- Enable the module
- Fix bugs if any

More details in the technical blog post: https://devs.x-cart.com/what_is_new/5_4_0_technology_preview_release.html

Thanks!

cflsystems 05-13-2019 03:08 AM

Re: X-Cart 5.4.0 Public Beta is out
 
Quote:

Originally Posted by mvs
The problem is that you cannot upload the module for X-Cart 5.3.6.x on X-Cart 5.4.0.x. And tar/tgz/tar.gz formats are acceptable.





That is not the problem. The module is manually uploaded to 5.4.x then converted to 5.4.x format. Tested and all works under 5.4.x. Then exported from 5.4.x to package and then trying to re-import back that very same package - error shows and the installation is not allowed. The cart will not even upload the module package due to "format not allowed" or something like this

mvs 05-13-2019 03:14 AM

Re: X-Cart 5.4.0 Public Beta is out
 
Quote:

Originally Posted by cflsystems
That is not the problem. The module is manually uploaded to 5.4.x then converted to 5.4.x format. Tested and all works under 5.4.x. Then exported from 5.4.x to package and then trying to re-import back that very same package - error shows and the installation is not allowed. The cart will not even upload the module package due to "format not allowed" or something like this

Please provide more details:
- screenshot with the error
- logs from xcart_folder/var/log

cflsystems 05-13-2019 04:56 AM

Re: X-Cart 5.4.0 Public Beta is out
 
1 Attachment(s)
Here with one of XC5 stock packages


The only log file created for this was service-request.log.2019-05-13.php with content


[2019-05-13 08:53:07] service-request.INFO: Matched route "{route}". {"route":"POST_package_chunk","route_parameters":{ "_controller":"XCart\\Bus\\Controller\\Package:upl oadAction","_route":"POST_package_chunk"},"request _uri":"http://localhost/xcart54dev/service.php/package/chunk?%2Fpackage%2Fchunk","method":"POST"} []
[2019-05-13 08:53:07] service-request.DEBUG: > POST /xcart54dev/service.php/package/chunk [] []
[2019-05-13 08:53:07] service-request.DEBUG: < 400 [] []

mvs 05-15-2019 12:16 AM

Re: X-Cart 5.4.0 Public Beta is out
 
We released the new Public Beta version (5.4.0.3), please check.
Changelog: https://devs.x-cart.com/changelog/5.4.0.3_-_15_may_2019.html
Download: https://www.x-cart.com/xc54beta

Triple A Racing 05-15-2019 07:22 PM

Re: X-Cart 5.4.0 Public Beta is out
 
Please read other people's related threads / posts first. This post only relates to the public beta release > XC 5.4.0.3 not any other XC release.
Quote:

Originally Posted by Ruslan
About your question on MariaDB: X-Cart 5.4 is fully compatible with MariaDB 10.2.* and higher. It is just an issue with the requirements checker. We will fix it

That's been fixed and the install ran very smoothly this time (Dev Store in our signature below) Thank you.
Quote:

Originally Posted by Ruslan
As to Nginx, you can find the "nginx.conf.sample" config in the root of your X-Cart store. It is an example of Nginx config for X-Cart 5.4. (It contains two versions of the config: with and without a web dir).We are unable to remove the .htaccess files from the X-Cart distribution package, but those files are blocked by Nginx config rule
-----
location ~* (\.php$|\.htaccess$|\.git) {
deny all;
}
-----

We referred to this, in post #5 then commented in post #7 of this thread, where we hopefully made our own thoughts clear.
As is currently provided, yes, there's definite progress, but we still think this is just a stick-on Nginx 'plaster' as opposed to being a pure, well designed Nginx only version of XC5 :wink:
Quote:

Originally Posted by Ruslan
As to CSP header, it is disabled by default because we cannot add rules for 3-d party modules. But we will prepare a tutorial with the proper directives for CSP in X-Cart 5.4.

We commented in post #7 of this thread. FWIW the default settings within ~/xcart/etc/config.php obviously do still remain as:
Code:

; Content-Security-Policy value

; ~ edit ~

content_security_policy = 'disabled'

The previous answer from @Ruslan shown above, relates to why.
However, we can't find the CSP tutorial yet (but we're assuming that this will be posted very soon?) :D/
This CSP setup for XC5 tutorial IS needed to fully test this XC 5.4.0.3 public beta release and provide useful feedback, especially, when using modules that may/will be effected by using CSP.
If / when needed by anybody, two useful reference links for CSP are these: Security Headers (site-test) and Scott Helme (CSP tagged articles)

mvs 05-16-2019 03:44 AM

Re: X-Cart 5.4.0 Public Beta is out
 
Quote:

However, we can't find the CSP tutorial yet (but we're assuming that this will be posted very soon?)
Currently, this is not a prior task. Unfortunately, this tutorial will not be included in 5.4.0.x Stable release.

Thank you for testing! Please let me know if you find anything else.
You're helping create a better product!


All times are GMT -8. The time now is 09:09 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.