X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   X-Payments issues & questions (https://forum.x-cart.com/forumdisplay.php?f=50)
-   -   X-Payments 3.1.4 Issues (https://forum.x-cart.com/showthread.php?t=76572)

CenturyPerf 10-03-2018 01:49 PM

X-Payments 3.1.4 Issues
 
I received (as the rest of us did) the announcement today stating a new version (3.1.4) of X-Payments was released. Unfortunately, the upgrade process fails without error. Meaning, pieces of X-Payments are now missing. I've created a support ticket, and am now anxiously waiting for a hopefully prompt response, for the connection between X-Payment and every store now fails.

1) Dashboard page is completely blank
2) Configuration bundle and other connection info no longer exists

I wish X-Cart had a posted article on how to quickly and easily restore X-Payments from the backups created during the upgrade process.

Based upon the "normal response time" ridiculousness for those of us unwilling to pay for overpriced support plans, I'll be restoring the server itself.

I would suggest waiting to upgrade your X-Payments, or be prepared to roll back to a prior version.

CenturyPerf 10-03-2018 06:33 PM

Re: X-Payments 3.1.4 Issues
 
Interesting error code.

X-cart recommends PHP version 7.2. Then, use code in X-Payments 3.1.4 that was depreciated in PHP 7.1.

Based on this error, the problem seems to be that the code doesn't support PHP 7.2.

Quote:

Error: Uncaught Error: Call to undefined function mcrypt_module_open() in lib/XPay/Crypt/Cypher/Rijndael256.php:164

Isn't it true that Mcrypt was deprecated in PHP 7.1, and removed entirely from 7.2? Given that X-Payments 3.1.4 seems to either be using code deprecated in 7.1, or not properly removed within this update from 3.1.3, someone at X-Cart needs to get to work solving this problem.

Interestingly, when I change the site to PHP 7.0 all I get is a 500 error and the login page will not load at all.

----
Looking at the new files I extracted onto my system (If I were to install a fresh 3.1.4 version), there isn't any "Rijndael256" file, unless it is something created by the install, or that this is a leftover that was not properly removed during various updates. When I use FTP to look at what is on the server, I see that file and that it was modified today.

The PHP error from the log files show this error in previous days also. However, X-Payments was working properly prior to the update to 3.1.4.

ambal 10-04-2018 01:46 AM

Re: X-Payments 3.1.4 Issues
 
Sam,

I advise contacting our techs about this incomplete upgrade issue. Most likely it is caused by some wrong file/folder permissions issue. MCrypt usage was removed a long time ago. See https://www.x-payments.com/help/X-Payments:System_requirements_for_X-Payments_3:

Quote:

mcrypt (Required only if upgrading X-Payments from a 3.0.x version; not needed if installing X-Payments version 3.1.0 or later. In 3.1.0 mcrypt has been replaced with openssl).


"Rijndael256" file is not a part of X-Payments anymore either.

CenturyPerf 10-04-2018 03:14 PM

Re: X-Payments 3.1.4 Issues
 
2 Attachment(s)
I would agree Ambal, that deprecated files should not exist if the update process properly removed them.

Since X-Cart's Ransom Support has yet to respond to the ticket created yesterday, I went ahead and installed a fresh version of X-Payments 3.1.4 and new database. This has solved "almost" all of the issues.

As I mention in the support ticket, The one issue that still exists, and has been a problem for some time. No matter which web browser is used (Chrome, Firefox, Edge, Opera, Avast), upon reaching the checkout page, the payment template (where credit card data is entered) often does not populate without refreshing the page.

It does not seem to be on my end, as I've had a few customers complain that they had nowhere to enter credit card data at checkout. I've also had others perform tests, and sometimes the CC template from X-Payments loads, and other times it does not.

I've attached two images showing the checkout page upon initial arrival and then after having to manually refresh the page.

***Additional issue that "might" have been corrected with this fresh install of X-Payments. There were times where shipping charges did not properly transfer to X-Payments. I do not know if the behavior will occur with the fresh install of X-Payments, only time will tell. The total would show properly at checkout, but X-Payments would return an error that shipping charges did not match. Obviously, the totals were not properly communicating between the site and X-Payments.


All times are GMT -8. The time now is 09:02 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.