X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   Dev Questions (https://forum.x-cart.com/forumdisplay.php?f=20)
-   -   Advanced Product Reviews - Review won't launch (https://forum.x-cart.com/showthread.php?t=77914)

peggyr 07-18-2020 08:24 AM

Advanced Product Reviews - Review won't launch
 
1 Attachment(s)
Hi,

I'm testing the Advanced Product Review module. I have custom reviews disabled (which have never been enabled on my site).

I have added a review, authorized it, it appears on the product page, but when I click on it, nothing launches, and the link shows "javascript:;"

I do not have popups blocked - I've checked the logs for errors, I have logged onto the DB/table and the review looks fine in the SQL table. I've cleared cache, temp files, etc.

Am I missing some other setup? Thanks for any ideas on what to check.

Peggy

cflsystems 07-18-2020 11:06 AM

Re: Advanced Product Reviews - Review won't launch
 
That woudl probably be the skin yu are using not properly adding the link for the reviews page or not loading some js needed for that.

PhilJ 07-19-2020 02:19 AM

Re: Advanced Product Reviews - Review won't launch
 
Clicking on that link should select and scroll to the reviews tab.

If you'd prefer it linked to the product reviews page instead, edit /skin/reboot/modules/Advanced_Customer_Reviews/vote_bar_basic.tpl

Replace...
Code:

javascript:;
With
Code:

reviews.php?productid={$product.productid}

peggyr 07-19-2020 05:01 PM

Re: Advanced Product Reviews - Review won't launch
 
Hi Phil,

My problem with product reviews not appearing, is I did NOT have 'Display reviews' was checked in reDUX

All is good now.

Thanks Steve and Phil

Peggy


All times are GMT -8. The time now is 12:26 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.