X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   Dev Questions (X-Cart 5) (https://forum.x-cart.com/forumdisplay.php?f=56)
-   -   Clean URLs in 5.2.5 (https://forum.x-cart.com/showthread.php?t=72271)

razortw 10-05-2015 06:04 AM

Re: Clean URLs in 5.2.5
 
Quote:

Originally Posted by Phil Richman
Did you go under "look & feel" - "Performance" and clear the cache?

Yes I did.
That didn't make it work.
So, the checklist is:
1. Install the mod.
2. Remove clean URL extensions in the database.
2. Clear aggregation cache and widget cache.
3. Re-deploy the store.
Is that correct?

Phil Richman 10-09-2015 12:06 PM

Re: Clean URLs in 5.2.5
 
1 Attachment(s)
Quote:

Originally Posted by razortw
Yes I did.
That didn't make it work.
So, the checklist is:
1. Install the mod.
2. Remove clean URL extensions in the database.
2. Clear aggregation cache and widget cache.
3. Re-deploy the store.
Is that correct?



I did a clean install of 5.2.6 on my development server. I found and fixed the problem with my mod. I have uploaded the fixed version please install it and let me know if you have any problems.

razortw 10-12-2015 02:46 AM

Re: Clean URLs in 5.2.5
 
Quote:

Originally Posted by Phil Richman
I did a clean install of 5.2.6 on my development server. I found and fixed the problem with my mod. I have uploaded the fixed version please install it and let me know if you have any problems.

It does work. Cool, thank you.
I hope other users will find this mod useful.
Thanks :)

shaz 12-20-2015 08:40 PM

Re: Clean URLs in 5.2.5
 
Experiencing the same issue with clean-urls not appearing in the site map on a few XC5 sites.

Has this been resolved as yet or do we have to use the mod?

Quote:

2. Remove clean URL extensions in the database.

Can you claify step 2?

XC5.2.10
XML sitemap 5.2.5
Site map 5.2.2

shaz 12-21-2015 04:48 PM

Re: Clean URLs in 5.2.5
 
Ok so it appears someone from xcart actually logged in and fixed them on my sites over night.... but as soon as I refreshed the xml sitemap it went back to the non-seo urls :/

Can whoever fixed this please do it again.... and would be GREAT if you could let me know how you did it....

info@shadowgraphicsinc.co 01-23-2016 05:20 PM

Re: Clean URLs in 5.2.5
 
I am having an issue in 5.2.6 where I am getting a loop when trying to call up the category via category #

http://www.horrormerchstore.com/shop/?target=category&category_id=1129
should point to
http://www.horrormerchstore.com/shop/horror-movies/movies/mars-attacks

but it just ends up in a loop.

I am trying to modify the Next/Previous module and placing a "view more products from (category) here. Where I can get it to show the category name, but it shows that category # URL and then sends it to a loop.

Also that loop also shows up on our sitemap for categories/subcategories as well.

Please let me know how to get rid of that loop.

Also as a side question, why did categories change from
http://www.shopurl.com/category to
http://www.shopurl.com/category/subcategory/subcategory/subcategory/finalsubcategory/

as that is a bit harder to just type up for link sharing.

Or is there something I am missing otherwise to do that as (in the example above) http://www.horrormerchstore.com/shop/mars-attacks shows as a page not found and
http://www.horrormerchstore.com/shop/horror-movies/movies/mars-attacks works

thanks!!

galoadm 08-16-2018 12:33 PM

Re: Clean URLs in 5.2.5
 
Quote:

Originally Posted by Phil Richman
I did a clean install of 5.2.6 on my development server. I found and fixed the problem with my mod. I have uploaded the fixed version please install it and let me know if you have any problems.



Just what I am looking for. Do you possibly have this Mod available for version 5.3.5.5?


In 5.3.5.5 I have set category_clean_urls_format = "domain/parent/goalcategory/" in config.php, but the .html is still at the end of the URL. Redeployed the store and no change. Deleted the .html from the URL in the database and resulted in a 404 error.

qualiteam 08-17-2018 03:31 AM

Re: Clean URLs in 5.2.5
 
Quote:

Originally Posted by galoadm
Just what I am looking for. Do you possibly have this Mod available for version 5.3.5.5?


In 5.3.5.5 I have set category_clean_urls_format = "domain/parent/goalcategory/" in config.php, but the .html is still at the end of the URL. Redeployed the store and no change. Deleted the .html from the URL in the database and resulted in a 404 error.



Did you try regenerating X-Cart cache after your edited the database?

jrowberg2 10-01-2018 10:10 AM

Re: Clean URLs in 5.2.5
 
I too would love for this plugin to work in 5.3.5.5. I had it working for a while in earlier versions, but it seems to have stopped (particularly for the static pages, not for the products at least on my end).

It is certainly curious why the .html extension is still required in the core code. For all the amazingness that X-Cart is, that bit in the URL is a throwback to the internet of 15 years ago. :?

qualiteam 10-01-2018 11:16 PM

Re: Clean URLs in 5.2.5
 
Quote:

Originally Posted by jrowberg2
I too would love for this plugin to work in 5.3.5.5. I had it working for a while in earlier versions, but it seems to have stopped (particularly for the static pages, not for the products at least on my end).

It is certainly curious why the .html extension is still required in the core code. For all the amazingness that X-Cart is, that bit in the URL is a throwback to the internet of 15 years ago. :?



You can fix the module yourself, the platform is fully open source :wink:
https://devs.x-cart.com/basics/


All times are GMT -8. The time now is 03:15 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.